Bootstrap 3 - Supporting Internet Explorer 8 and 9

Posted by on in Blog

Bootstrap v3 is built to work best in the latest desktop and mobile browsers, meaning older browsers might display differently, eventhough fully functional the renderings of certain components may not work the same.

So what shoukd I do?

For the full Bootstrap 3 explanation, please see here:
http://getbootstrap.com/getting-started/#browsers

Steps

1. Download a copy of the following files:

https://code.google.com/p/html5shiv

https://github.com/scottjehl/Respond

2. Drop the 2 above files into the following folder on your server:

/templates/your-template/js

3. Place the following code in the head of your templates index.php file
Note: place the code directly after the last css file that is going to be loaded. 

 

<!--[if lt IE 9]>
<script src="/js/html5shiv.js" type="text/javascript"></script>
<script src="/js/respond.min.js" type="text/javascript"></script>
<![endif]-->

 

Obviously for Joomla users, you will have to edit the above code (as below) to include the base URL and echo your template that is in use.

ie html5shiv respond

 

Extra Notes:

a) Make sure that you are in Compatibility mode in your IE browser

b) Be aware that some local MAMP & WAMP setups will not support the above - so test on your server.

One Last Trick

Try adding the following CSS:

.container
{
    display:table;
    width: 100%;
}
.row
{
    height: 100%;
    display: table-row;
}
.col-sm-4
{
    display: table-cell;
}
Last modified on
blog comments powered by Disqus

Supporting Partners

stackideas
sobipro
k2
akeebabackup
jomsocial
jce editor

 

Our Preferred Joomla Host's

Web Hosting

Get in Touch With us

For account or Joostrap enquiries, please get in touch with us here.

Contact us